What’s Vulnerable › Vulnerabilities
CVE-2022-39295: Improper Neutralization of Alternate XSS Syntax in Knowage-Server
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-10-13 · updated 2026-06-17
- Weakness: CWE-79
Description
Knowage is an open source suite for modern business analytics alternative over big data systems. KnowageLabs / Knowage-Server starting with the 6.x branch and prior to versions 7.4.22, 8.0.9, and 8.1.0 is vulnerable to cross-site scripting because the `XSSRequestWrapper::stripXSS` method can be bypassed. Versions 7.4.22, 8.0.9, and 8.1.0 contain patches for this issue. There are no known workarounds.
Affected products
- KnowageLabs Knowage-Server: from 6.1.0 before 7.4.22; from 8.0.0 before 8.0.9 — fixed in 7.4.22, 8.0.9
How to fix
Upgrade to a fixed version: KnowageLabs Knowage-Server 7.4.22, 8.0.9. Check the vendor advisory for mitigations.
References
- https://github.com/KnowageLabs/Knowage-Server/blob/b079a654c1708f82f6914c55be6715ad621d9edd/knowageutils/src/main/java/it/eng/spagobi/utilities/filters/XSSRequestWrapper.java#L82-L206
- https://github.com/KnowageLabs/Knowage-Server/security/advisories/GHSA-f2gr-6h9j-rwcw
- https://github.com/KnowageLabs/Knowage-Server/blob/b079a654c1708f82f6914c55be6715ad621d9edd/knowageutils/src/main/java/it/eng/spagobi/utilities/filters/XSSRequestWrapper.java#L82-L206
- https://github.com/KnowageLabs/Knowage-Server/security/advisories/GHSA-f2gr-6h9j-rwcw
Get alerted when CVE-2022-39295 or the next vulnerability affects your stack