What’s Vulnerable › Vulnerabilities
CVE-2022-39297: Deserialization of untrusted data in MelisCms
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-10-12 · updated 2026-06-17
- Weakness: CWE-502
Description
MelisCms provides a full CMS for Melis Platform, including templating system, drag'n'drop of plugins, SEO and many administration tools. Attackers can deserialize arbitrary data on affected versions of `melisplatform/melis-cms`, and ultimately leads to the execution of arbitrary PHP code on the system. Conducting this attack does not require authentication. Users should immediately upgrade to `melisplatform/melis-cms` >= 5.0.1. This issue was addressed by restricting allowed classes when deserializing user-controlled data.
Affected products
- Melistechnology Meliscms: before 5.0.1 — fixed in 5.0.1
How to fix
Upgrade to a fixed version: Melistechnology Meliscms 5.0.1. Check the vendor advisory for mitigations.
References
- https://github.com/melisplatform/melis-cms/commit/d124b2474699a679a24ec52620cadceb3d4cec11
- https://github.com/melisplatform/melis-cms/security/advisories/GHSA-m3m3-6gww-7gj9
- https://github.com/melisplatform/melis-cms/commit/d124b2474699a679a24ec52620cadceb3d4cec11
- https://github.com/melisplatform/melis-cms/security/advisories/GHSA-m3m3-6gww-7gj9
Get alerted when CVE-2022-39297 or the next vulnerability affects your stack