What’s Vulnerable › Vulnerabilities

CVE-2022-39299: Signature bypass via multiple root elements in Passport-SAML

Description

Passport-SAML is a SAML 2.0 authentication provider for Passport, the Node.js authentication library. A remote attacker may be able to bypass SAML authentication on a website using passport-saml. A successful attack requires that the attacker is in possession of an arbitrary IDP signed XML element. Depending on the IDP used, fully unauthenticated attacks (e.g without access to a valid user) might also be feasible if generation of a signed message can be triggered. Users should upgrade to passport-saml version 3.2.2 or newer. The issue was also present in the beta releases of `node-saml` before version 4.0.0-beta.5. If you cannot upgrade, disabling SAML authentication may be done as a workaround.

Affected products

How to fix

Upgrade to a fixed version: node-saml passport-saml 3.2.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-39299 or the next vulnerability affects your stack