What’s Vulnerable › Vulnerabilities
CVE-2022-39300: Signature bypass via multiple root elements in node-SAML
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-10-13 · updated 2026-06-17
- Weakness: CWE-347
Description
node SAML is a SAML 2.0 library based on the SAML implementation of passport-saml. A remote attacker may be able to bypass SAML authentication on a website using passport-saml. A successful attack requires that the attacker is in possession of an arbitrary IDP signed XML element. Depending on the IDP used, fully unauthenticated attacks (e.g without access to a valid user) might also be feasible if generation of a signed message can be triggered. Users should upgrade to node-saml version 4.0.0-beta5 or newer. Disabling SAML authentication may be done as a workaround.
Affected products
- node-saml: before 4.0.0; 4.0.0-beta0, 4.0.0-beta1, 4.0.0-beta2, 4.0.0-beta3, 4.0.0-beta4 — fixed in 4.0.0
How to fix
Upgrade to a fixed version: node-saml 4.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/node-saml/node-saml/commit/c1f275c289c01921e58f5c70ce0fdbc5287e5fbe
- https://github.com/node-saml/node-saml/security/advisories/GHSA-5p8w-2mvw-38pv
- https://github.com/node-saml/node-saml/commit/c1f275c289c01921e58f5c70ce0fdbc5287e5fbe
- https://github.com/node-saml/node-saml/security/advisories/GHSA-5p8w-2mvw-38pv
Get alerted when CVE-2022-39300 or the next vulnerability affects your stack