What’s Vulnerable › Vulnerabilities
CVE-2022-39311: Compromised agents may be able to execute remote code on GoCD Server
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-10-14 · updated 2026-06-17
- Weakness: CWE-502
Description
GoCD is a continuous delivery server. GoCD helps you automate and streamline the build-test-release cycle for continuous delivery of your product. GoCD versions prior to 21.1.0 are vulnerable to remote code execution on the server from a malicious or compromised agent. The Spring RemoteInvocation endpoint exposed agent communication and allowed deserialization of arbitrary java objects, as well as subsequent remote code execution. Exploitation requires agent-level authentication, thus an attacker would need to either compromise an existing agent, its network communication or register a new agent to practically exploit this vulnerability. This issue is fixed in GoCD version 21.1.0. There are currently no known workarounds.
Affected products
- gocd: before 21.1.0 — fixed in 21.1.0
How to fix
Upgrade to a fixed version: gocd 21.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/gocd/gocd/commit/7b88b70d6f7f429562d5cab49a80ea856e34cdc8
- https://github.com/gocd/gocd/security/advisories/GHSA-2hjh-3p3p-8hcm
- https://www.gocd.org/releases/#21-1-0
- https://github.com/gocd/gocd/commit/7b88b70d6f7f429562d5cab49a80ea856e34cdc8
- https://github.com/gocd/gocd/security/advisories/GHSA-2hjh-3p3p-8hcm
- https://www.gocd.org/releases/#21-1-0
Get alerted when CVE-2022-39311 or the next vulnerability affects your stack