What’s Vulnerable › Vulnerabilities
CVE-2022-39312: Dataease Mysql Data Source JDBC Connection Parameters Not Verified Leads to Deserialization Vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-10-25 · updated 2026-06-17
- Weakness: CWE-20
Description
Dataease is an open source data visualization analysis tool. Dataease prior to 1.15.2 has a deserialization vulnerability. In Dataease, the Mysql data source in the data source function can customize the JDBC connection parameters and the Mysql server target to be connected. In `backend/src/main/java/io/dataease/provider/datasource/JdbcProvider.java`, the `MysqlConfiguration` class does not filter any parameters. If an attacker adds some parameters to a JDBC url and connects to a malicious mysql server, the attacker can trigger the mysql jdbc deserialization vulnerability. Through the deserialization vulnerability, the attacker can execute system commands and obtain server privileges. Version 1.15.2 contains a patch for this issue.
Affected products
- dataease: before 1.15.2 — fixed in 1.15.2
How to fix
Upgrade to a fixed version: dataease 1.15.2. Check the vendor advisory for mitigations.
References
- https://github.com/dataease/dataease/commit/956ee2d6c9e81349a60aef435efc046888e10a6d
- https://github.com/dataease/dataease/pull/3328
- https://github.com/dataease/dataease/releases/tag/v1.15.2
- https://github.com/dataease/dataease/security/advisories/GHSA-q4qq-jhjv-7rh2
- https://github.com/dataease/dataease/commit/956ee2d6c9e81349a60aef435efc046888e10a6d
- https://github.com/dataease/dataease/pull/3328
- https://github.com/dataease/dataease/releases/tag/v1.15.2
- https://github.com/dataease/dataease/security/advisories/GHSA-q4qq-jhjv-7rh2
Get alerted when CVE-2022-39312 or the next vulnerability affects your stack