What’s Vulnerable › Vulnerabilities
CVE-2022-39313: Parse Server crashes when receiving file download request with invalid byte range
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-10-24 · updated 2026-06-17
- Weakness: CWE-1284
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Versions prior to 4.10.17, and prior to 5.2.8 on the 5.x branch, crash when a file download request is received with an invalid byte range, resulting in a Denial of Service. This issue has been patched in versions 4.10.17, and 5.2.8. There are no known workarounds.
Affected products
- parse-community parse-server: before 4.10.17; from 5.0.0 before 5.2.8 — fixed in 4.10.17, 5.2.8
How to fix
Upgrade to a fixed version: parse-community parse-server 4.10.17, 5.2.8. Check the vendor advisory for mitigations.
References
- https://github.com/parse-community/parse-server/security/advisories/GHSA-h423-w6qv-2wj3
- https://github.com/parse-community/parse-server/security/advisories/GHSA-h423-w6qv-2wj3
Get alerted when CVE-2022-39313 or the next vulnerability affects your stack