What’s Vulnerable › Vulnerabilities
CVE-2022-39314: User enumeration in the code-based login and password reset forms
- Severity: low (CVSS 3.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-10-24 · updated 2026-06-17
- Weakness: CWE-307
Description
Kirby is a flat-file CMS. In versions prior to 3.5.8.2, 3.6.6.2, 3.7.5.1, and 3.8.1, Kirby is subject to user enumeration due to Improper Restriction of Excessive Authentication Attempts. This vulnerability affects you only if you are using the `code` or `password-reset` auth method with the `auth.methods` option or if you have enabled the `debug` option in production. By using two or more IP addresses and multiple login attempts, valid user accounts will lock, but invalid accounts will not, leading to account enumeration. This issue has been patched in versions 3.5.8.2, 3.6.6.2, 3.7.5.1, and 3.8.1. If you cannot update immediately, you can work around the issue by setting the `auth.methods` option to `password`, which disables the code-based login and password reset forms.
Affected products
- getkirby kirby: before 3.5.8.2; from 3.6.0 before 3.6.6.2; from 3.7.0 before 3.7.5.1; 3.8.0, 3.8.0-rc1, 3.8.0-rc2, 3.8.0-rc3 — fixed in 3.5.8.2, 3.6.6.2, 3.7.5.1
How to fix
Upgrade to a fixed version: getkirby kirby 3.5.8.2, 3.6.6.2, 3.7.5.1. Check the vendor advisory for mitigations.
References
- https://github.com/getkirby/kirby/security/advisories/GHSA-43qq-qw4x-28f8
- https://github.com/getkirby/kirby/security/advisories/GHSA-43qq-qw4x-28f8
Get alerted when CVE-2022-39314 or the next vulnerability affects your stack