What’s Vulnerable › Vulnerabilities

CVE-2022-39315: Kirby CMS vulnerable to user enumeration in the brute force protection

Description

Kirby is a Content Management System. Prior to versions 3.5.8.2, 3.6.6.2, 3.7.5.1, and 3.8.1, a user enumeration vulnerability affects all Kirby sites with user accounts unless Kirby's API and Panel are disabled in the config. It can only be exploited for targeted attacks because the attack does not scale to brute force. The problem has been patched in Kirby 3.5.8.2, Kirby 3.6.6.2, Kirby 3.7.5.1, and Kirby 3.8.1. In all of the mentioned releases, the maintainers have rewritten the affected code so that the delay is also inserted after the brute force limit is reached.

Affected products

How to fix

Upgrade to a fixed version: getkirby kirby 3.5.8.2, 3.6.6.2, 3.7.5.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-39315 or the next vulnerability affects your stack