What’s Vulnerable › Vulnerabilities
CVE-2022-39322: @keystone-6/core vulnerable to field-level access-control bypass for multiselect field
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-10-25 · updated 2026-06-17
- Weakness: CWE-285
Description
@keystone-6/core is a core package for Keystone 6, a content management system for Node.js. Starting with version 2.2.0 and prior to version 2.3.1, users who expected their `multiselect` fields to use the field-level access control - if configured - are vulnerable to their field-level access control not being used. List-level access control is not affected. Field-level access control for fields other than `multiselect` are not affected. Version 2.3.1 contains a fix for this issue. As a workaround, stop using the `multiselect` field.
Affected products
- keystonejs keystone: from 2.2.0 before 2.3.1 — fixed in 2.3.1
How to fix
Upgrade to a fixed version: keystonejs keystone 2.3.1. Check the vendor advisory for mitigations.
References
- https://github.com/keystonejs/keystone/commit/65c6ee3deef23605fc72b80230908696a7a65e7c
- https://github.com/keystonejs/keystone/security/advisories/GHSA-6mhr-52mv-6v6f
- https://github.com/keystonejs/keystone/commit/65c6ee3deef23605fc72b80230908696a7a65e7c
- https://github.com/keystonejs/keystone/security/advisories/GHSA-6mhr-52mv-6v6f
Get alerted when CVE-2022-39322 or the next vulnerability affects your stack