What’s Vulnerable › Vulnerabilities
CVE-2022-39327: Improper Control of Generation of Code ('Code Injection') in Azure CLI
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-10-25 · updated 2026-06-17
- Weakness: CWE-94
Description
Azure CLI is the command-line interface for Microsoft Azure. In versions previous to 2.40.0, Azure CLI contains a vulnerability for potential code injection. Critical scenarios are where a hosting machine runs an Azure CLI command where parameter values have been provided by an external source. The vulnerability is only applicable when the Azure CLI command is run on a Windows machine and with any version of PowerShell and when the parameter value contains the `&` or `|` symbols. If any of these prerequisites are not met, this vulnerability is not applicable. Users should upgrade to version 2.40.0 or greater to receive a a mitigation for the vulnerability.
Affected products
- Microsoft Azure CLI: before 2.40.0 — fixed in 2.40.0
- Microsoft Azure CLI: before 2.40.0
How to fix
Upgrade to a fixed version: Microsoft Azure CLI 2.40.0. Check the vendor advisory for mitigations.
References
- https://github.com/Azure/azure-cli/pull/23514
- https://github.com/Azure/azure-cli/pull/24015
- https://github.com/Azure/azure-cli/security/advisories/GHSA-47xc-9rr2-q7p4
- https://github.com/Azure/azure-cli/pull/23514
- https://github.com/Azure/azure-cli/pull/24015
- https://github.com/Azure/azure-cli/security/advisories/GHSA-47xc-9rr2-q7p4
Get alerted when CVE-2022-39327 or the next vulnerability affects your stack