What’s Vulnerable › Vulnerabilities
CVE-2022-39331: Cross-site Scripting (XSS) in Nexcloud Desktop Client
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-11-25 · updated 2026-06-17
- Weakness: CWE-79
Description
Nexcloud desktop is the Desktop sync client for Nextcloud. An attacker can inject arbitrary HyperText Markup Language into the Desktop Client application in the notifications. It is recommended that the Nextcloud Desktop client is upgraded to 3.6.1. There are no known workarounds for this issue.
Affected products
- Desktop Client: before 3.6.1 — fixed in 3.6.1
How to fix
Upgrade to a fixed version: Desktop Client 3.6.1. Check the vendor advisory for mitigations.
References
- https://github.com/nextcloud/desktop/pull/4944
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-c3xh-q694-6rc5
- https://hackerone.com/reports/1668028
- https://github.com/nextcloud/desktop/pull/4944
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-c3xh-q694-6rc5
- https://hackerone.com/reports/1668028
- https://lists.debian.org/debian-lts-announce/2025/09/msg00018.html
Get alerted when CVE-2022-39331 or the next vulnerability affects your stack