What’s Vulnerable › Vulnerabilities
CVE-2022-39334: nextcloudcmd incorrectly trusts bad TLS certificates
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-11-25 · updated 2026-06-17
- Weakness: CWE-295
Description
Nextcloud also ships a CLI utility called nextcloudcmd which is sometimes used for automated scripting and headless servers. Versions of nextcloudcmd prior to 3.6.1 would incorrectly trust invalid TLS certificates, which may enable a Man-in-the-middle attack that exposes sensitive data or credentials to a network attacker. This affects the CLI only. It does not affect the standard GUI desktop Nextcloud clients, and it does not affect the Nextcloud server.
Affected products
- Desktop Client: before 3.6.1 — fixed in 3.6.1
How to fix
Upgrade to a fixed version: Desktop Client 3.6.1. Check the vendor advisory for mitigations.
References
- https://github.com/nextcloud/desktop/issues/4927
- https://github.com/nextcloud/desktop/pull/5022
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-82xx-98xv-4jxv
- https://hackerone.com/reports/1699740
- https://github.com/nextcloud/desktop/issues/4927
- https://github.com/nextcloud/desktop/pull/5022
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-82xx-98xv-4jxv
- https://hackerone.com/reports/1699740
- https://lists.debian.org/debian-lts-announce/2025/09/msg00018.html
Get alerted when CVE-2022-39334 or the next vulnerability affects your stack