What’s Vulnerable › Vulnerabilities
CVE-2022-39335: Synapse does not apply enough checks to servers requesting auth events of events in a room
- Severity: medium (CVSS 5.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-05-26 · updated 2026-06-17
- Weakness: CWE-200
Description
Synapse is an open-source Matrix homeserver written and maintained by the Matrix.org Foundation. The Matrix Federation API allows remote homeservers to request the authorization events in a room. This is necessary so that a homeserver receiving some events can validate that those events are legitimate and permitted in their room. However, in versions of Synapse up to and including 1.68.0, a Synapse homeserver answering a query for authorization events does not sufficiently check that the requesting server should be able to access them. The issue was patched in Synapse 1.69.0. Homeserver administrators are advised to upgrade.
Affected products
- matrix-org synapse: before 1.69.0 — fixed in 1.69.0
How to fix
Upgrade to a fixed version: matrix-org synapse 1.69.0. Check the vendor advisory for mitigations.
References
- https://github.com/matrix-org/synapse/issues/13288
- https://github.com/matrix-org/synapse/pull/13823
- https://github.com/matrix-org/synapse/security/advisories/GHSA-45cj-f97f-ggwv
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/T2MBNMZAFY4RCZL2VGBGAPKGB4JUPZVS/
- https://github.com/matrix-org/synapse/issues/13288
- https://github.com/matrix-org/synapse/pull/13823
- https://github.com/matrix-org/synapse/security/advisories/GHSA-45cj-f97f-ggwv
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/T2MBNMZAFY4RCZL2VGBGAPKGB4JUPZVS/
Get alerted when CVE-2022-39335 or the next vulnerability affects your stack