What’s Vulnerable › Vulnerabilities
CVE-2022-39338: Stored cross site scripting (XSS) vulnerability via Authorization Endpoint in user_oidc
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-25 · updated 2026-06-17
- Weakness: CWE-20
Description
user_oidc is an OpenID Connect user backend for Nextcloud. Versions prior to 1.2.1 did not properly validate discovery urls which may lead to a stored cross site scripting attack vector. The impact is limited due to the restrictive CSP that is applied on this endpoint. Additionally this vulnerability has only been shown to be exploitable in the Safari web browser. This issue has been addressed in version 1.2.1. Users are advised to upgrade. Users unable to upgrade should urge their users to avoid using the Safari web browser.
Affected products
- nextcloud Openid Connect User Backend: before 1.2.1 — fixed in 1.2.1
How to fix
Upgrade to a fixed version: nextcloud Openid Connect User Backend 1.2.1. Check the vendor advisory for mitigations.
References
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-5fpw-795h-rg57
- https://github.com/nextcloud/user_oidc/pull/496
- https://hackerone.com/reports/1687410
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-5fpw-795h-rg57
- https://github.com/nextcloud/user_oidc/pull/496
- https://hackerone.com/reports/1687410
Get alerted when CVE-2022-39338 or the next vulnerability affects your stack