What’s Vulnerable › Vulnerabilities
CVE-2022-39340: OpenFGA Information Disclosure
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-10-25 · updated 2026-06-17
- Weakness: CWE-285
Description
OpenFGA is an authorization/permission engine. Prior to version 0.2.4, the `streamed-list-objects` endpoint was not validating the authorization header, resulting in disclosure of objects in the store. Users `openfga/openfga` versions 0.2.3 and prior who are exposing the OpenFGA service to the internet are vulnerable. Version 0.2.4 contains a patch for this issue.
Affected products
- openfga: before 0.2.4 — fixed in 0.2.4
How to fix
Upgrade to a fixed version: openfga 0.2.4. Check the vendor advisory for mitigations.
References
- https://github.com/openfga/openfga/commit/779d73d4b6d067ee042ec9b59fec707eed71e42f
- https://github.com/openfga/openfga/releases/tag/v0.2.4
- https://github.com/openfga/openfga/security/advisories/GHSA-95x7-mh78-7w2r
- https://github.com/openfga/openfga/commit/779d73d4b6d067ee042ec9b59fec707eed71e42f
- https://github.com/openfga/openfga/releases/tag/v0.2.4
- https://github.com/openfga/openfga/security/advisories/GHSA-95x7-mh78-7w2r
Get alerted when CVE-2022-39340 or the next vulnerability affects your stack