What’s Vulnerable › Vulnerabilities
CVE-2022-39341: OpenFGA Authorization Bypass
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-10-25 · updated 2026-06-17
- Weakness: CWE-285
Description
OpenFGA is an authorization/permission engine. Versions prior to version 0.2.4 are vulnerable to authorization bypass under certain conditions. Users who have wildcard (`*`) defined on tupleset relations in their authorization model are vulnerable. Version 0.2.4 contains a patch for this issue.
Affected products
- openfga: before 0.2.4 — fixed in 0.2.4
How to fix
Upgrade to a fixed version: openfga 0.2.4. Check the vendor advisory for mitigations.
References
- https://github.com/openfga/openfga/commit/b466769cc100b2065047786578718d313f52695b
- https://github.com/openfga/openfga/releases/tag/v0.2.4
- https://github.com/openfga/openfga/security/advisories/GHSA-vj4m-83m8-xpw5
- https://github.com/openfga/openfga/commit/b466769cc100b2065047786578718d313f52695b
- https://github.com/openfga/openfga/releases/tag/v0.2.4
- https://github.com/openfga/openfga/security/advisories/GHSA-vj4m-83m8-xpw5
Get alerted when CVE-2022-39341 or the next vulnerability affects your stack