What’s Vulnerable › Vulnerabilities
CVE-2022-3935: Welcart e-Commerce < 2.8.4 - Multiple Subscriber+ Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-12-12 · updated 2026-06-17
Description
The Welcart e-Commerce WordPress plugin before 2.8.4 does not sanitise and escape some parameters, which could allow any authenticated users, such as subscriber to perform Stored Cross-Site Scripting attacks
Affected products
- Welcart e-Commerce: before 2.8.4 — fixed in 2.8.4
How to fix
Upgrade to a fixed version: Welcart e-Commerce 2.8.4. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/906c5122-dd6d-494b-b66c-4162e234ea05
- https://wpscan.com/vulnerability/906c5122-dd6d-494b-b66c-4162e234ea05
Get alerted when CVE-2022-3935 or the next vulnerability affects your stack