What’s Vulnerable › Vulnerabilities
CVE-2022-39352: OpenFGA Authorization Bypass
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-08 · updated 2026-06-17
- Weakness: CWE-863
Description
OpenFGA is a high-performance authorization/permission engine inspired by Google Zanzibar. Versions prior to 0.2.5 are vulnerable to authorization bypass under certain conditions. You are affected by this vulnerability if you added a tuple with a wildcard (*) assigned to a tupleset relation (the right hand side of a ‘from’ statement). This issue has been patched in version v0.2.5. This update is not backward compatible with any authorization model that uses wildcard on a tupleset relation.
Affected products
- openfga: before 0.2.5 — fixed in 0.2.5
How to fix
Upgrade to a fixed version: openfga 0.2.5. Check the vendor advisory for mitigations.
References
- https://github.com/openfga/openfga/security/advisories/GHSA-3gfj-fxx4-f22w
- https://github.com/openfga/openfga/security/advisories/GHSA-3gfj-fxx4-f22w
Get alerted when CVE-2022-39352 or the next vulnerability affects your stack