What’s Vulnerable › Vulnerabilities
CVE-2022-39356: Discourse user account takeover via email and invite link
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-02 · updated 2026-06-17
- Weakness: CWE-285
Description
Discourse is a platform for community discussion. Users who receive an invitation link that is not scoped to a single email address can enter any non-admin user's email and gain access to their account when accepting the invitation. All users should upgrade to the latest version. A workaround is temporarily disabling invitations with `SiteSetting.max_invites_per_day = 0` or scope them to individual email addresses.
Affected products
- discourse: before 2.8.10; 2.9.0-beta1, 2.9.0-beta10, 2.9.0-beta2, 2.9.0-beta3, 2.9.0-beta4, 2.9.0-beta5 (+4) — fixed in 2.8.10
How to fix
Upgrade to a fixed version: discourse 2.8.10. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/pull/18817
- https://github.com/discourse/discourse/security/advisories/GHSA-x8w7-rwmr-w278
- https://github.com/discourse/discourse/pull/18817
- https://github.com/discourse/discourse/security/advisories/GHSA-x8w7-rwmr-w278
Get alerted when CVE-2022-39356 or the next vulnerability affects your stack