What’s Vulnerable › Vulnerabilities

CVE-2022-39358: Metabase vulnerable to circumvention of Locked parameter in Signed Embedding

Description

Metabase is data visualization software. Prior to versions 0.44.5, 1.44.5, 0.43.7, 1.43.7, 0.42.6, and 1.42.6, it was possible to circumvent locked parameters when requesting data for a question in an embedded dashboard by constructing a malicious request to the backend. This issue is patched in versions 0.44.5, 1.44.5, 0.43.7, 1.43.7, 0.42.6, and 1.42.6.

Affected products

How to fix

Upgrade to a fixed version: metabase 0.42.6, 0.43.7, 0.44.5, 1.42.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-39358 or the next vulnerability affects your stack