What’s Vulnerable › Vulnerabilities
CVE-2022-39360: Metabase SSO users able to circumvent IdP login by doing password reset
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-10-26 · updated 2026-06-17
- Weakness: CWE-287
Description
Metabase is data visualization software. Prior to versions 0.44.5, 1.44.5, 0.43.7, 1.43.7, 0.42.6, 1.42.6, 0.41.9, and 1.41.9 single sign on (SSO) users were able to do password resets on Metabase, which could allow a user access without going through the SSO IdP. This issue is patched in versions 0.44.5, 1.44.5, 0.43.7, 1.43.7, 0.42.6, 1.42.6, 0.41.9, and 1.41.9. Metabase now blocks password reset for all users who use SSO for their Metabase login.
Affected products
- metabase: from 0.41.0 before 0.41.9; from 0.42.0 before 0.42.6; from 0.43.0 before 0.43.7; from 0.44.0 before 0.44.5; from 1.41.0 before 1.41.9; from 1.42.0 before 1.42.6 — fixed in 0.41.9, 0.42.6, 0.43.7, 0.44.5, 1.41.9, 1.42.6
How to fix
Upgrade to a fixed version: metabase 0.41.9, 0.42.6, 0.43.7, 0.44.5. Check the vendor advisory for mitigations.
References
- https://github.com/metabase/metabase/commit/edadf7303c3b068609f57ca073e67885d5c98730
- https://github.com/metabase/metabase/security/advisories/GHSA-gw4g-ww2m-v7vc
- https://github.com/metabase/metabase/commit/edadf7303c3b068609f57ca073e67885d5c98730
- https://github.com/metabase/metabase/security/advisories/GHSA-gw4g-ww2m-v7vc
Get alerted when CVE-2022-39360 or the next vulnerability affects your stack