What’s Vulnerable › Vulnerabilities
CVE-2022-39361: Metabase vulnerable to Remote Code Execution via H2
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-10-26 · updated 2026-06-17
- Weakness: CWE-20
Description
Metabase is data visualization software. Prior to versions 0.44.5, 1.44.5, 0.43.7, 1.43.7, 0.42.6, 1.42.6, 0.41.9, and 1.41.9, H2 (Sample Database) could allow Remote Code Execution (RCE), which can be abused by users able to write SQL queries on H2 databases. This issue is patched in versions 0.44.5, 1.44.5, 0.43.7, 1.43.7, 0.42.6, 1.42.6, 0.41.9, and 1.41.9. Metabase no longer allows DDL statements in H2 native queries.
Affected products
- metabase: from 0.41.0 before 0.41.9; from 0.42.0 before 0.42.6; from 0.43.0 before 0.43.7; from 0.44.0 before 0.44.5; from 1.41.0 before 1.41.9; from 1.42.0 before 1.42.6 — fixed in 0.41.9, 0.42.6, 0.43.7, 0.44.5, 1.41.9, 1.42.6
How to fix
Upgrade to a fixed version: metabase 0.41.9, 0.42.6, 0.43.7, 0.44.5. Check the vendor advisory for mitigations.
References
- https://github.com/metabase/metabase/security/advisories/GHSA-gqpj-wcr3-p88v
- https://github.com/metabase/metabase/security/advisories/GHSA-gqpj-wcr3-p88v
Get alerted when CVE-2022-39361 or the next vulnerability affects your stack