What’s Vulnerable › Vulnerabilities

CVE-2022-39362: Metabase vulnerable to arbitrary SQL execution from queryhash

Description

Metabase is data visualization software. Prior to versions 0.44.5, 1.44.5, 0.43.7, 1.43.7, 0.42.6, 1.42.6, 0.41.9, and 1.41.9, unsaved SQL queries are auto-executed, which could pose a possible attack vector. This issue is patched in versions 0.44.5, 1.44.5, 0.43.7, 1.43.7, 0.42.6, 1.42.6, 0.41.9, and 1.41.9. Metabase no longer automatically executes ad-hoc native queries. Now the native editor shows the query and gives the user the option to manually run the query if they want.

Affected products

How to fix

Upgrade to a fixed version: metabase 0.41.9, 0.42.6, 0.43.7, 0.44.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-39362 or the next vulnerability affects your stack