What’s Vulnerable › Vulnerabilities
CVE-2022-39365: RCE vulnerability in Pimcore/Mail & Dynamic Text Layout
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-10-27 · updated 2026-06-17
- Weakness: CWE-94
Description
Pimcore is an open source data and experience management platform. Prior to version 10.5.9, the user controlled twig templates rendering in `Pimcore/Mail` & `ClassDefinition\Layout\Text` is vulnerable to server-side template injection, which could lead to remote code execution. Version 10.5.9 contains a patch for this issue. As a workaround, one may apply the patch manually.
Affected products
- pimcore/pimcore: before 10.5.9 — fixed in 10.5.9
How to fix
Upgrade to a fixed version: pimcore/pimcore 10.5.9. Check the vendor advisory for mitigations.
References
- https://github.com/pimcore/pimcore/commit/43aa34e018f5cd447bceb864358285ba92f68372
- https://github.com/pimcore/pimcore/pull/13347
- https://github.com/pimcore/pimcore/pull/13347.patch
- https://github.com/pimcore/pimcore/security/advisories/GHSA-5qxq-vgmm-q39m
- https://github.com/pimcore/pimcore/commit/43aa34e018f5cd447bceb864358285ba92f68372
- https://github.com/pimcore/pimcore/pull/13347
- https://github.com/pimcore/pimcore/pull/13347.patch
- https://github.com/pimcore/pimcore/security/advisories/GHSA-5qxq-vgmm-q39m
Get alerted when CVE-2022-39365 or the next vulnerability affects your stack