What’s Vulnerable › Vulnerabilities
CVE-2022-39384: OpenZeppelin Contracts initializer reentrancy may lead to double initialization
- Severity: medium (CVSS 5.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-04 · updated 2026-06-17
- Weakness: CWE-665
Description
OpenZeppelin Contracts is a library for secure smart contract development. Before version 4.4.1 but after 3.2.0, initializer functions that are invoked separate from contract creation (the most prominent example being minimal proxies) may be reentered if they make an untrusted non-view external call. Once an initializer has finished running it can never be re-executed. However, an exception put in place to support multiple inheritance made reentrancy possible in the scenario described above, breaking the expectation that there is a single execution. Note that upgradeable proxies are commonly initialized together with contract creation, where reentrancy is not feasible, so the impact of this issue is believed to be minor. This issue has been patched, please upgrade to version 4.4.1. As a workaround, avoid untrusted external calls during initialization.
Affected products
- openzeppelin-contracts: from 3.2.0 before 4.4.1 — fixed in 4.4.1
- OpenZeppelin Contracts Upgradeable: from 3.2.0 before 4.4.1 — fixed in 4.4.1
How to fix
Upgrade to a fixed version: openzeppelin-contracts 4.4.1; OpenZeppelin Contracts Upgradeable 4.4.1. Check the vendor advisory for mitigations.
References
- https://github.com/OpenZeppelin/openzeppelin-contracts/pull/3006
- https://github.com/OpenZeppelin/openzeppelin-contracts/security/advisories/GHSA-9c22-pwxw-p6hx
- https://github.com/OpenZeppelin/openzeppelin-contracts/pull/3006
- https://github.com/OpenZeppelin/openzeppelin-contracts/security/advisories/GHSA-9c22-pwxw-p6hx
Get alerted when CVE-2022-39384 or the next vulnerability affects your stack