What’s Vulnerable › Vulnerabilities
CVE-2022-39386: fastify-websocket vulnerable to uncaught exception via crash on malformed packet
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-08 · updated 2026-06-17
- Weakness: CWE-248
Description
@fastify/websocket provides WebSocket support for Fastify. Any application using @fastify/websocket could crash if a specific, malformed packet is sent. All versions of fastify-websocket are also impacted. That module is deprecated, so it will not be patched. This has been patched in version 7.1.1 (fastify v4) and version 5.0.1 (fastify v3). There are currently no known workarounds. However, it should be possible to attach the error handler manually. The recommended path is upgrading to the patched versions.
Affected products
- fastify-websocket: from 6.0.0 before 7.1.1; 5.0.0 — fixed in 7.1.1
How to fix
Upgrade to a fixed version: fastify-websocket 7.1.1. Check the vendor advisory for mitigations.
References
- https://github.com/fastify/fastify-websocket/security/advisories/GHSA-4pcg-wr6c-h9cq
- https://github.com/fastify/fastify-websocket/security/advisories/GHSA-4pcg-wr6c-h9cq
Get alerted when CVE-2022-39386 or the next vulnerability affects your stack