What’s Vulnerable › Vulnerabilities
CVE-2022-39387: XWiki OIDC Authenticator vulnerable to OpenID login bypass due to improper authentication
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-04 · updated 2026-06-17
- Weakness: CWE-287
Description
XWiki OIDC has various tools to manipulate OpenID Connect protocol in XWiki. Prior to version 1.29.1, even if a wiki has an OpenID provider configured through its xwiki.properties, it is possible to provide a third party provider its details through request parameters. One can then bypass the XWiki authentication altogether by specifying its own provider through the oidc.endpoint.* request parameters (or by using an XWiki-based OpenID provider with oidc.xwikiprovider. With the same approach, one could also provide a specific group mapping through oidc.groups.mapping that would make his user automatically part of the XWikiAdminGroup. This issue has been patched, please upgrade to 1.29.1. There is no workaround, an upgrade of the authenticator is required.
Affected products
- xwiki Openid Connect: before 1.29.1 — fixed in 1.29.1
How to fix
Upgrade to a fixed version: xwiki Openid Connect 1.29.1. Check the vendor advisory for mitigations.
References
- https://github.com/xwiki-contrib/oidc/commit/0247af1417925b9734ab106ad7cd934ee870ac89
- https://github.com/xwiki-contrib/oidc/security/advisories/GHSA-m7gv-v8xx-v47w
- https://jira.xwiki.org/browse/OIDC-118
- https://github.com/xwiki-contrib/oidc/commit/0247af1417925b9734ab106ad7cd934ee870ac89
- https://github.com/xwiki-contrib/oidc/security/advisories/GHSA-m7gv-v8xx-v47w
- https://jira.xwiki.org/browse/OIDC-118
Get alerted when CVE-2022-39387 or the next vulnerability affects your stack