What’s Vulnerable › Vulnerabilities
CVE-2022-3946: Welcart e-Commerce < 2.8.4 - Subscriber+ Arbitrary Shipping Method Creation/Update/Deletion
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-12-12 · updated 2026-06-17
- Weakness: CWE-352
Description
The Welcart e-Commerce WordPress plugin before 2.8.4 does not have authorisation and CSRF in an AJAX action, allowing any logged-in user to create, update and delete shipping methods.
Affected products
- Welcart e-Commerce: before 2.8.4 — fixed in 2.8.4
How to fix
Upgrade to a fixed version: Welcart e-Commerce 2.8.4. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/b48e4e1d-e682-4b16-81dc-2feee78d7ed0
- https://wpscan.com/vulnerability/b48e4e1d-e682-4b16-81dc-2feee78d7ed0
Get alerted when CVE-2022-3946 or the next vulnerability affects your stack