What’s Vulnerable › Vulnerabilities
CVE-2022-3957: GPAC SVG Parser svg_attributes.c svg_parse_preserveaspectratio memory leak
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-11 · updated 2026-06-17
- Weakness: CWE-404
Description
A vulnerability classified as problematic was found in GPAC. Affected by this vulnerability is the function svg_parse_preserveaspectratio of the file scenegraph/svg_attributes.c of the component SVG Parser. The manipulation leads to memory leak. The attack can be launched remotely. The name of the patch is 2191e66aa7df750e8ef01781b1930bea87b713bb. It is recommended to apply a patch to fix this issue. The associated identifier of this vulnerability is VDB-213463.
Affected products
- GPAC: before 2.2.0 — fixed in 2.2.0
How to fix
Upgrade to a fixed version: GPAC 2.2.0. Check the vendor advisory for mitigations.
References
- https://github.com/gpac/gpac/commit/2191e66aa7df750e8ef01781b1930bea87b713bb
- https://vuldb.com/?id.213463
- https://www.debian.org/security/2023/dsa-5411
- https://github.com/gpac/gpac/commit/2191e66aa7df750e8ef01781b1930bea87b713bb
- https://vuldb.com/?id.213463
- https://www.debian.org/security/2023/dsa-5411
Get alerted when CVE-2022-3957 or the next vulnerability affects your stack