What’s Vulnerable › Vulnerabilities
CVE-2022-3964: ffmpeg QuickTime RPZA Video Encoder rpzaenc.c out-of-bounds
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-13 · updated 2026-06-17
- Weakness: CWE-119
Description
A vulnerability classified as problematic has been found in ffmpeg. This affects an unknown part of the file libavcodec/rpzaenc.c of the component QuickTime RPZA Video Encoder. The manipulation of the argument y_size leads to out-of-bounds read. It is possible to initiate the attack remotely. The name of the patch is 92f9b28ed84a77138105475beba16c146bdaf984. It is recommended to apply a patch to fix this issue. The associated identifier of this vulnerability is VDB-213543.
Affected products
- FFmpeg: from 4.4 before 4.4.4; from 5.0 before 5.0.3; from 5.1 before 5.1.3 — fixed in 4.4.4, 5.0.3, 5.1.3
How to fix
Upgrade to a fixed version: FFmpeg 4.4.4, 5.0.3, 5.1.3. Check the vendor advisory for mitigations.
References
- https://git.ffmpeg.org/gitweb/ffmpeg.git/commit/92f9b28ed84a77138105475beba16c146bdaf984
- https://security.gentoo.org/glsa/202312-14
- https://vuldb.com/?id.213543
- https://git.ffmpeg.org/gitweb/ffmpeg.git/commit/92f9b28ed84a77138105475beba16c146bdaf984
- https://security.gentoo.org/glsa/202312-14
- https://vuldb.com/?id.213543
Get alerted when CVE-2022-3964 or the next vulnerability affects your stack