What’s Vulnerable › Vulnerabilities
CVE-2022-3965: ffmpeg QuickTime Graphics Video Encoder smcenc.c smc_encode_stream out-of-bounds
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-13 · updated 2026-06-17
- Weakness: CWE-119
Description
A vulnerability classified as problematic was found in ffmpeg. This vulnerability affects the function smc_encode_stream of the file libavcodec/smcenc.c of the component QuickTime Graphics Video Encoder. The manipulation of the argument y_size leads to out-of-bounds read. The attack can be initiated remotely. The name of the patch is 13c13109759090b7f7182480d075e13b36ed8edd. It is recommended to apply a patch to fix this issue. The identifier of this vulnerability is VDB-213544.
Affected products
- FFmpeg: from 5.0 before 5.0.3; from 5.1 before 5.1.3 — fixed in 5.0.3, 5.1.3
How to fix
Upgrade to a fixed version: FFmpeg 5.0.3, 5.1.3. Check the vendor advisory for mitigations.
References
- https://git.ffmpeg.org/gitweb/ffmpeg.git/commit/13c13109759090b7f7182480d075e13b36ed8edd
- https://security.gentoo.org/glsa/202312-14
- https://vuldb.com/?id.213544
- https://git.ffmpeg.org/gitweb/ffmpeg.git/commit/13c13109759090b7f7182480d075e13b36ed8edd
- https://security.gentoo.org/glsa/202312-14
- https://vuldb.com/?id.213544
Get alerted when CVE-2022-3965 or the next vulnerability affects your stack