What’s Vulnerable › Vulnerabilities
CVE-2022-3966: Ultimate Member Plugin Template class-shortcodes.php load_template pathname traversal
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-13 · updated 2026-06-17
- Weakness: CWE-22
Description
A vulnerability, which was classified as critical, has been found in Ultimate Member Plugin up to 2.5.0. This issue affects the function load_template of the file includes/core/class-shortcodes.php of the component Template Handler. The manipulation of the argument tpl leads to pathname traversal. The attack may be initiated remotely. Upgrading to version 2.5.1 is able to address this issue. The name of the patch is e1bc94c1100f02a129721ba4be5fbc44c3d78ec4. It is recommended to upgrade the affected component. The identifier VDB-213545 was assigned to this vulnerability.
Affected products
- ultimatemember Ultimate Member – User Profile, Registration, Login, Member Directory, Content Restriction & Membership P: before 2.5.1 — fixed in 2.5.1
How to fix
Upgrade to a fixed version: ultimatemember Ultimate Member – User Profile, Registration, Login, Member Directory, Content Restriction & Membership P 2.5.1. Check the vendor advisory for mitigations.
References
- https://github.com/ultimatemember/ultimatemember/commit/e1bc94c1100f02a129721ba4be5fbc44c3d78ec4
- https://github.com/ultimatemember/ultimatemember/releases/tag/2.5.1
- https://vuldb.com/?id.213545
- https://github.com/ultimatemember/ultimatemember/commit/e1bc94c1100f02a129721ba4be5fbc44c3d78ec4
- https://github.com/ultimatemember/ultimatemember/releases/tag/2.5.1
- https://vuldb.com/?id.213545
Get alerted when CVE-2022-3966 or the next vulnerability affects your stack