What’s Vulnerable › Vulnerabilities
CVE-2022-3978: NodeBB abort cross-site request forgery
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-11-13 · updated 2026-06-17
- Weakness: CWE-863
Description
A vulnerability, which was classified as problematic, was found in NodeBB up to 2.5.7. This affects an unknown part of the file /register/abort. The manipulation leads to cross-site request forgery. It is possible to initiate the attack remotely. Upgrading to version 2.5.8 is able to address this issue. The name of the patch is 2f9d8c350e54543f608d3d4c8e1a49bbb6cdea38. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-213555.
Affected products
- NodeBB: before 2.5.8 — fixed in 2.5.8
How to fix
Upgrade to a fixed version: NodeBB 2.5.8. Check the vendor advisory for mitigations.
References
- https://github.com/NodeBB/NodeBB/commit/2f9d8c350e54543f608d3d4c8e1a49bbb6cdea38
- https://github.com/NodeBB/NodeBB/issues/11017
- https://github.com/NodeBB/NodeBB/releases/tag/v2.5.8
- https://vuldb.com/?id.213555
- https://github.com/NodeBB/NodeBB/commit/2f9d8c350e54543f608d3d4c8e1a49bbb6cdea38
- https://github.com/NodeBB/NodeBB/issues/11017
- https://github.com/NodeBB/NodeBB/releases/tag/v2.5.8
- https://vuldb.com/?id.213555
Get alerted when CVE-2022-3978 or the next vulnerability affects your stack