What’s Vulnerable › Vulnerabilities
CVE-2022-3983: Checkout for PayPal < 1.0.14 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-12-19 · updated 2026-06-17
Description
The Checkout for PayPal WordPress plugin before 1.0.14 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks
Affected products
- Checkout for PayPal: before 1.0.14 — fixed in 1.0.14
How to fix
Upgrade to a fixed version: Checkout for PayPal 1.0.14. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/0b48bbd6-7c77-44b8-a5d6-34e4a0747cf1
- https://wpscan.com/vulnerability/0b48bbd6-7c77-44b8-a5d6-34e4a0747cf1
Get alerted when CVE-2022-3983 or the next vulnerability affects your stack