What’s Vulnerable › Vulnerabilities
CVE-2022-3984: Flowplayer Video Player < 1.0.5 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-12-19 · updated 2026-06-17
Description
The Flowplayer Video Player WordPress plugin before 1.0.5 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks
Affected products
- Flowplayer Video Player: before 1.0.5 — fixed in 1.0.5
How to fix
Upgrade to a fixed version: Flowplayer Video Player 1.0.5. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/b4694e9d-3f38-4295-929d-0ad37b3cbbaa
- https://wpscan.com/vulnerability/b4694e9d-3f38-4295-929d-0ad37b3cbbaa
Get alerted when CVE-2022-3984 or the next vulnerability affects your stack