What’s Vulnerable › Vulnerabilities
CVE-2022-39842
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-05 · updated 2026-06-17
- Weakness: CWE-190
Description
An issue was discovered in the Linux kernel before 5.19. In pxa3xx_gcu_write in drivers/video/fbdev/pxa3xx-gcu.c, the count parameter has a type conflict of size_t versus int, causing an integer overflow and bypassing the size check. After that, because it is used as the third argument to copy_from_user(), a heap overflow may occur. NOTE: the original discoverer disputes that the overflow can actually happen.
Affected products
- Debian Linux: 10.0, 11.0
- Linux kernel: before 5.19; 5.19-rc1, 5.19-rc2, 5.19-rc3 — fixed in 5.19
How to fix
Upgrade to a fixed version: Linux kernel 5.19. Check the vendor advisory for mitigations.
References
- https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.19
- https://github.com/torvalds/linux/commit/a09d2d00af53b43c6f11e6ab3cb58443c2cac8a7
- https://lists.debian.org/debian-lts-announce/2022/10/msg00000.html
- https://lists.debian.org/debian-lts-announce/2022/11/msg00001.html
- https://lore.kernel.org/all/YylaC1wHHyLw22D3%40kadam/T/
- https://www.debian.org/security/2022/dsa-5257
- https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.19
- https://github.com/torvalds/linux/commit/a09d2d00af53b43c6f11e6ab3cb58443c2cac8a7
- https://lists.debian.org/debian-lts-announce/2022/10/msg00000.html
- https://lists.debian.org/debian-lts-announce/2022/11/msg00001.html
- https://lore.kernel.org/all/YylaC1wHHyLw22D3%40kadam/T/
- https://www.debian.org/security/2022/dsa-5257
Get alerted when CVE-2022-39842 or the next vulnerability affects your stack