What’s Vulnerable › Vulnerabilities
CVE-2022-3985: Videojs HTML5 Player < 1.1.9 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-12-19 · updated 2026-06-17
Description
The Videojs HTML5 Player WordPress plugin before 1.1.9 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks
Affected products
- Videojs HTML5 Player: before 1.1.9 — fixed in 1.1.9
How to fix
Upgrade to a fixed version: Videojs HTML5 Player 1.1.9. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/58f82e13-153e-41e8-a22b-a2e96b46a6dc
- https://wpscan.com/vulnerability/58f82e13-153e-41e8-a22b-a2e96b46a6dc
Get alerted when CVE-2022-3985 or the next vulnerability affects your stack