What’s Vulnerable › Vulnerabilities
CVE-2022-3986: WP Stripe Checkout < 1.2.2.21 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-12-19 · updated 2026-06-17
Description
The WP Stripe Checkout WordPress plugin before 1.2.2.21 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks
Affected products
- WP Stripe Checkout: before 1.2.2.21 — fixed in 1.2.2.21
How to fix
Upgrade to a fixed version: WP Stripe Checkout 1.2.2.21. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/ad8077a1-7cbe-4aa1-ad7d-acb41027ed0a
- https://wpscan.com/vulnerability/ad8077a1-7cbe-4aa1-ad7d-acb41027ed0a
Get alerted when CVE-2022-3986 or the next vulnerability affects your stack