What’s Vulnerable › Vulnerabilities
CVE-2022-3987: Responsive Lightbox2 < 1.0.4 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-12-19 · updated 2026-06-17
- Weakness: CWE-79
Description
The Responsive Lightbox2 WordPress plugin before 1.0.4 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks
Affected products
- Responsive Lightbox2: before 1.0.4 — fixed in 1.0.4
How to fix
Upgrade to a fixed version: Responsive Lightbox2 1.0.4. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/d9309a09-34ba-4e56-b683-e677ad277b29
- https://wpscan.com/vulnerability/d9309a09-34ba-4e56-b683-e677ad277b29
Get alerted when CVE-2022-3987 or the next vulnerability affects your stack