What’s Vulnerable › Vulnerabilities
CVE-2022-39944: The Apache Linkis JDBC EngineConn module has a RCE Vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-10-26 · updated 2026-06-17
- Weakness: CWE-502
Description
In Apache Linkis <=1.2.0 when used with the MySQL Connector/J, a deserialization vulnerability with possible remote code execution impact exists when an attacker has write access to a database and configures a JDBC EC with a MySQL data source and malicious parameters. Therefore, the parameters in the jdbc url should be blacklisted. Versions of Apache Linkis <= 1.2.0 will be affected, We recommend users to update to 1.3.0.
Affected products
- Apache Software Foundation Apache Linkis: through 1.2.0
References
- https://lists.apache.org/thread/rxytj48q17304snonjtyt5lnlw64gccc
- https://lists.apache.org/thread/rxytj48q17304snonjtyt5lnlw64gccc
Get alerted when CVE-2022-39944 or the next vulnerability affects your stack