What’s Vulnerable › Vulnerabilities
CVE-2022-39954
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-16 · updated 2026-06-17
- Weakness: CWE-611
Description
An improper restriction of xml external entity reference in Fortinet FortiNAC version 9.4.0 through 9.4.1, FortiNAC version 9.2.0 through 9.2.7, FortiNAC version 9.1.0 through 9.1.8, FortiNAC version 8.8.0 through 8.8.11, FortiNAC version 8.7.0 through 8.7.6, FortiNAC version 8.6.0 through 8.6.5, FortiNAC version 8.5.0 through 8.5.4, FortiNAC version 8.3.7 allows attacker to read arbitrary files or trigger a denial of service via specifically crafted XML documents.
Affected products
- Fortinet FortiNAC: from 8.3.7 through 9.2.7; from 9.4.0 before 9.4.2 — fixed in 9.4.2
- Fortinet FortiNAC-F: before 7.2.0 — fixed in 7.2.0
How to fix
Upgrade to a fixed version: Fortinet FortiNAC 9.4.2; Fortinet FortiNAC-F 7.2.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-39954 or the next vulnerability affects your stack