What’s Vulnerable › Vulnerabilities
CVE-2022-40023
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-09-07 · updated 2026-06-17
- Weakness: CWE-1333
Description
Sqlalchemy mako before 1.2.2 is vulnerable to Regular expression Denial of Service when using the Lexer class to parse. This also affects babelplugin and linguaplugin.
Affected products
- Debian Linux: 10.0
- sqlalchemy mako: before 1.2.2 — fixed in 1.2.2
How to fix
Upgrade to a fixed version: sqlalchemy mako 1.2.2. Check the vendor advisory for mitigations.
References
- https://github.com/sqlalchemy/mako/blob/c2f392e0be52dc67d1b9770ab8cce6a9c736d547/mako/ext/extract.py#L21
- https://github.com/sqlalchemy/mako/commit/925760291d6efec64fda6e9dd1fd9cfbd5be068c
- https://github.com/sqlalchemy/mako/issues/366
- https://lists.debian.org/debian-lts-announce/2022/09/msg00026.html
- https://pyup.io/posts/pyup-discovers-redos-vulnerabilities-in-top-python-packages/
- https://pyup.io/vulnerabilities/CVE-2022-40023/50870/
- https://github.com/sqlalchemy/mako/blob/c2f392e0be52dc67d1b9770ab8cce6a9c736d547/mako/ext/extract.py#L21
- https://github.com/sqlalchemy/mako/commit/925760291d6efec64fda6e9dd1fd9cfbd5be068c
- https://github.com/sqlalchemy/mako/issues/366
- https://lists.debian.org/debian-lts-announce/2022/09/msg00026.html
- https://lists.debian.org/debian-lts-announce/2025/12/msg00004.html
- https://pyup.io/posts/pyup-discovers-redos-vulnerabilities-in-top-python-packages/
Get alerted when CVE-2022-40023 or the next vulnerability affects your stack