What’s Vulnerable › Vulnerabilities
CVE-2022-4009
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-16 · updated 2026-06-17
- Weakness: CWE-77
Description
In affected versions of Octopus Deploy it is possible for a user to introduce code via offline package creation
Affected products
- Octopus Deploy Octopus Server: from 3.0.19 before 2022.2.8552; from 2022.3.348 before 2022.3.10750; from 2022.4.791 before 2022.4.8319 — fixed in 2022.2.8552, 2022.3.10750, 2022.4.8319
How to fix
Upgrade to a fixed version: Octopus Deploy Octopus Server 2022.2.8552, 2022.3.10750, 2022.4.8319. Check the vendor advisory for mitigations.
References
- https://advisories.octopus.com/post/2023/sa2023-05/
- https://advisories.octopus.com/post/2023/sa2023-05/
Get alerted when CVE-2022-4009 or the next vulnerability affects your stack