What’s Vulnerable › Vulnerabilities
CVE-2022-40127: Apache Airflow <2.4.0 has an RCE in a bash example
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 85.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-11-14 · updated 2026-06-17
- Weakness: CWE-94
Description
A vulnerability in Example Dags of Apache Airflow allows an attacker with UI access who can trigger DAGs, to execute arbitrary commands via manually provided run_id parameter. This issue affects Apache Airflow Apache Airflow versions prior to 2.4.0.
Affected products
- Apache Airflow: before 2.4.0 — fixed in 2.4.0
How to fix
Upgrade to a fixed version: Apache Airflow 2.4.0. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2022/11/14/2
- https://github.com/apache/airflow/pull/25960
- https://lists.apache.org/thread/cf132hgm6jvzvsbpsozl3plf1r4cwysy
- http://www.openwall.com/lists/oss-security/2022/11/14/2
- https://github.com/apache/airflow/pull/25960
- https://lists.apache.org/thread/cf132hgm6jvzvsbpsozl3plf1r4cwysy
Get alerted when CVE-2022-40127 or the next vulnerability affects your stack