What’s Vulnerable › Vulnerabilities
CVE-2022-40147
- Severity: high (CVSS 7.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-10-11 · updated 2026-06-17
- Weakness: CWE-295
Description
A vulnerability has been identified in Industrial Edge Management (All versions < V1.5.1). The affected software does not properly validate the server certificate when initiating a TLS connection. This could allow an attacker to spoof a trusted entity by interfering in the communication path between the client and the intended server.
Affected products
- Siemens Industrial Edge Management: before 1.5.1 — fixed in 1.5.1
How to fix
Upgrade to a fixed version: Siemens Industrial Edge Management 1.5.1. Check the vendor advisory for mitigations.
References
- https://cert-portal.siemens.com/productcert/pdf/ssa-649853.pdf
- https://cert-portal.siemens.com/productcert/pdf/ssa-649853.pdf
Get alerted when CVE-2022-40147 or the next vulnerability affects your stack