What’s Vulnerable › Vulnerabilities
CVE-2022-40151: Stack Buffer Overflow in xstream
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-09-16 · updated 2026-06-17
- Weakness: CWE-121
Description
Those using Xstream to seralize XML data may be vulnerable to Denial of Service attacks (DOS). If the parser is running on user supplied input, an attacker may supply content that causes the parser to crash by stackoverflow. This effect may support a denial of service attack.
Affected products
- x-stream xstream: before 1.4.20 — fixed in 1.4.20
How to fix
Upgrade to a fixed version: x-stream xstream 1.4.20. Check the vendor advisory for mitigations.
References
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=47367
- https://github.com/x-stream/xstream/issues/304
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=47367
- https://github.com/x-stream/xstream/issues/304
Get alerted when CVE-2022-40151 or the next vulnerability affects your stack