What’s Vulnerable › Vulnerabilities
CVE-2022-40152: Stack Buffer Overflow in Woodstox
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 18.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-09-16 · updated 2026-06-17
- Weakness: CWE-121
Description
Those using Woodstox to parse XML data may be vulnerable to Denial of Service attacks (DOS) if DTD support is enabled. If the parser is running on user supplied input, an attacker may supply content that causes the parser to crash by stackoverflow. This effect may support a denial of service attack.
Affected products
- FasterXML Woodstox: before 5.4.0; from 6.0.0 before 6.4.0 — fixed in 5.4.0, 6.4.0
- x-stream xstream: before 1.4.20 — fixed in 1.4.20
How to fix
Upgrade to a fixed version: FasterXML Woodstox 5.4.0, 6.4.0; x-stream xstream 1.4.20. Check the vendor advisory for mitigations.
References
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=47434
- https://github.com/x-stream/xstream/issues/304
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=47434
- https://github.com/x-stream/xstream/issues/304
Get alerted when CVE-2022-40152 or the next vulnerability affects your stack