What’s Vulnerable › Vulnerabilities
CVE-2022-4016: Booster for WooCommerce - Custom Role Creation/Deletion via CSRF
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-12-12 · updated 2026-06-17
Description
The Booster for WooCommerce WordPress plugin before 5.6.7, Booster Plus for WooCommerce WordPress plugin before 5.6.6, Booster Elite for WooCommerce WordPress plugin before 1.1.8 does not properly check for CSRF when creating and deleting Customer roles, allowing attackers to make logged admins create and delete arbitrary custom roles via CSRF attacks
Affected products
- pluggabl Booster for WooCommerce – PDF Invoices, Abandoned Cart, Variation Swatches & 100+ Tools: before 1.1.8; before 5.6.6; before 5.6.7 — fixed in 1.1.8, 5.6.6, 5.6.7
How to fix
Upgrade to a fixed version: pluggabl Booster for WooCommerce – PDF Invoices, Abandoned Cart, Variation Swatches & 100+ Tools 1.1.8, 5.6.6, 5.6.7. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/9b77044c-fd3f-4e6f-a759-dcc3082dcbd6
- https://wpscan.com/vulnerability/9b77044c-fd3f-4e6f-a759-dcc3082dcbd6
Get alerted when CVE-2022-4016 or the next vulnerability affects your stack