What’s Vulnerable › Vulnerabilities
CVE-2022-40189: Apache Airlfow Pig Provider RCE
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-22 · updated 2026-06-17
- Weakness: CWE-78
Description
Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') vulnerability in Apache Airflow Pig Provider, Apache Airflow allows an attacker to control commands executed in the task execution context, without write access to DAG files. This issue affects Pig Provider versions prior to 4.0.0. It also impacts any Apache Airflow versions prior to 2.3.0 in case Pig Provider is installed (Pig Provider 4.0.0 can only be installed for Airflow 2.3.0+). Note that you need to manually install the Pig Provider version 4.0.0 in order to get rid of the vulnerability on top of Airflow 2.3.0+ version.
Affected products
- Apache Airflow: before 2.3.0 — fixed in 2.3.0
- Apache-Airflow-Providers-Apache-Pig: before 4.0.0 — fixed in 4.0.0
How to fix
Upgrade to a fixed version: Apache Airflow 2.3.0; Apache-Airflow-Providers-Apache-Pig 4.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/apache/airflow/pull/27644
- https://lists.apache.org/thread/yxnfzfw2w9pj5s785k3rlyly4y44sd15
- https://github.com/apache/airflow/pull/27644
- https://lists.apache.org/thread/yxnfzfw2w9pj5s785k3rlyly4y44sd15
Get alerted when CVE-2022-40189 or the next vulnerability affects your stack